Thread: floating point exception

Started: 2009-06-11 22:51:00
Last activity: 2009-06-11 23:21:01
Topics: SAC Help
Margaret Doll
2009-06-11 22:51:00
We have just installed sac 101.2 on a linux 64 bit computer running
RedHat. The SAC distribution was not a source distribution.

We are getting a "Floating point error" when we run the program. I
assume that our 64 bit libraries are causing the problem in that SAC
is a 32 bit program.

How can we fix the problem?

  • Brian Savage
    2009-06-11 23:21:01
    Margaret,

    Does the linux machine have the 32 bit libraries installed ?
    You can check which libraries sac is using by issuing the command

    % ldd /usr/local/sac/bin/sac

    Assuming sac is installed in the default location.
    My system has 32 and 64 bit libraries installed at
    32 bit library
    /lib/ld-linux.so.2
    64 bit library
    /lib64/ld-linux-x86-64.so.2

    The sac binary should be using for the first one.

    By the way, the 64 bit version of sac will be coming out soon.

    Brian Savage
    savage<at>uri.edu


    On Jun 11, 2009, at 3:51 PM , Margaret Doll wrote:

    We have just installed sac 101.2 on a linux 64 bit computer
    running RedHat. The SAC distribution was not a source distribution.

    We are getting a "Floating point error" when we run the program. I
    assume that our 64 bit libraries are causing the problem in that
    SAC is a 32 bit program.

    How can we fix the problem?
    _______________________________________________
    sac-help mailing list
    sac-help<at>iris.washington.edu
    http://www.iris.washington.edu/mailman/listinfo/sac-help


Page built 20:22:47 | v.b'59d0d2