Thread: 32 bit precision error message

Started: 2021-06-05 20:38:29
Last activity: 2021-06-09 18:26:05
Topics: SAC Help
Aubreya Adams
2021-06-05 20:38:29
I’ve just recently downloaded SAC (v102.0) onto a new loaner Mac (OS 10.15.7 Catalina) while my own is getting repairs. I’ve getting an error message like the one below when I read in data:

SAC> r XO.LT20..HHZ.M__at__2019-03-01T08.59.06.412Z.SAC
WARNING: minimum precision > sampling rate: t1 = 2392957.750000
sampling rate (delta): 0.010000
32-bit minimum precision: 0.250000
WARNING: minimum precision > sampling rate: t2 = 2392957.750000
sampling rate (delta): 0.010000
32-bit minimum precision: 0.250000

The machine I’m on is 64-bit. And the data file seems fine - I’ve read it on previous versions of sac on both Macs and Linux platforms.

Any ideas of what is going on or how I might fix this?

Thanks,
Aubreya

  • George Helffrich
    2021-06-09 13:04:47
    Dear Aubreya -

    What this message means is that the values in the T1 and T2 markers are so big that the coarseness of their 32 bit numerical representation is bigger than the sample rate. Most real numbers can’t be represented exactly digitally by a computer, but only with some imprecision. (The bigger a number is, the less precise it is.) When the imprecision of a SAC time marker (like T1 or T2 in the file header) can’t even pin the time down to within a given sample in the file, you will get this message.

    This message is new to newer versions of SAC, which is why you might not have seen it before.

    Whether this matters to you depends on what T1 and T2 mean. If they are markers for a signal onset, in the trace, that’s probably bad. If they are markers for when an earthquake happened relative to the zero time of the file, that may be OK if all they represent is a time window.

    SAC’s SYNCHRONIZE command can help change file times by moving the file’s zero time so that offsets from it (like T1 and T2) become smaller and can be represented more precisely. See section 4.6 in the SAC book for details about time representation in SAC files.

    On 9 Jun 2021, at 09:51, Aubreya Adams (via IRIS) <sac-help-bounce<at>lists.ds.iris.edu> wrote:

    I’ve just recently downloaded SAC (v102.0) onto a new loaner Mac (OS 10.15.7 Catalina) while my own is getting repairs. I’ve getting an error message like the one below when I read in data:

    SAC> r XO.LT20..HHZ.M__at__2019-03-01T08.59.06.412Z.SAC
    WARNING: minimum precision > sampling rate: t1 = 2392957.750000
    sampling rate (delta): 0.010000
    32-bit minimum precision: 0.250000
    WARNING: minimum precision > sampling rate: t2 = 2392957.750000
    sampling rate (delta): 0.010000
    32-bit minimum precision: 0.250000

    The machine I’m on is 64-bit. And the data file seems fine - I’ve read it on previous versions of sac on both Macs and Linux platforms.

    Any ideas of what is going on or how I might fix this?

    Thanks,
    Aubreya

    ----------------------
    SAC Help
    Topic home: http://ds.iris.edu/message-center/topic/sac-help/ | Unsubscribe: sac-help-unsubscribe<at>lists.ds.iris.edu

    Sent from the IRIS Message Center (http://ds.iris.edu/message-center/)
    Update subscription preferences at http://ds.iris.edu/account/profile/



    George Helffrich
    george<at>elsi.jp


    • Aubreya Adams
      2021-06-09 16:19:59
      Hello George,
      Thank you for this clarification. For some reason, my message went through a few days after I’d sent it, so I’ve had the opportunity to do some troubleshooting since my first email. I hadn’t realized that SAC header values were still stored as 32-bit, so I had been puzzled by the 32-bit precision, but now understand that. I also found that I only get this problem when I am downloading multiple events simultaneously from JWeed - perhaps some wires are getting crossed there, which is motivation for me to migrate to PyWeed! T1 and T2 are predicted phase arrival times, which I’m not using, and the origin and KZ times seem accurate, so I think I’m set.
      Many thanks!
      Aubreya

      On Jun 9, 2021, at 4:05 PM, George Helffrich (via IRIS) <sac-help-bounce<at>lists.ds.iris.edu> wrote:

      Dear Aubreya -

      What this message means is that the values in the T1 and T2 markers are so big that the coarseness of their 32 bit numerical representation is bigger than the sample rate. Most real numbers can’t be represented exactly digitally by a computer, but only with some imprecision. (The bigger a number is, the less precise it is.) When the imprecision of a SAC time marker (like T1 or T2 in the file header) can’t even pin the time down to within a given sample in the file, you will get this message.

      This message is new to newer versions of SAC, which is why you might not have seen it before.

      Whether this matters to you depends on what T1 and T2 mean. If they are markers for a signal onset, in the trace, that’s probably bad. If they are markers for when an earthquake happened relative to the zero time of the file, that may be OK if all they represent is a time window.

      SAC’s SYNCHRONIZE command can help change file times by moving the file’s zero time so that offsets from it (like T1 and T2) become smaller and can be represented more precisely. See section 4.6 in the SAC book for details about time representation in SAC files.

      On 9 Jun 2021, at 09:51, Aubreya Adams (via IRIS) <sac-help-bounce<at>lists.ds.iris.edu <sac-help-bounce<at>lists.ds.iris.edu>> wrote:

      I’ve just recently downloaded SAC (v102.0) onto a new loaner Mac (OS 10.15.7 Catalina) while my own is getting repairs. I’ve getting an error message like the one below when I read in data:

      SAC> r XO.LT20..HHZ.M__at__2019-03-01T08.59.06.412Z.SAC
      WARNING: minimum precision > sampling rate: t1 = 2392957.750000
      sampling rate (delta): 0.010000
      32-bit minimum precision: 0.250000
      WARNING: minimum precision > sampling rate: t2 = 2392957.750000
      sampling rate (delta): 0.010000
      32-bit minimum precision: 0.250000

      The machine I’m on is 64-bit. And the data file seems fine - I’ve read it on previous versions of sac on both Macs and Linux platforms.

      Any ideas of what is going on or how I might fix this?

      Thanks,
      Aubreya

      ----------------------
      SAC Help
      Topic home: http://ds.iris.edu/message-center/topic/sac-help/ | Unsubscribe: sac-help-unsubscribe<at>lists.ds.iris.edu <sac-help-unsubscribe<at>lists.ds.iris.edu>

      Sent from the IRIS Message Center (http://ds.iris.edu/message-center/)
      Update subscription preferences at http://ds.iris.edu/account/profile/



      George Helffrich
      george<at>elsi.jp <george<at>elsi.jp>

      ----------------------
      SAC Help
      Topic home: http://ds.iris.edu/message-center/topic/sac-help/ | Unsubscribe: sac-help-unsubscribe<at>lists.ds.iris.edu

      Sent from the IRIS Message Center (http://ds.iris.edu/message-center/)
      Update subscription preferences at http://ds.iris.edu/account/profile/


    • Brian Savage
      2021-06-09 16:32:20
      Aubreya,

      What George says is correct.

      The values of t1 and t2 are set at about 27 days (2392957.750000 s) from the zero time of the file.

      If your file is this a month long or longer, you might consider using the v7 header for sac. The v7 sac header accommodates 64 bits values for times and other header values that *might* require the extra precision. This may cause issues if you use v7 version of the file with programs external to sac because the v7 sac header is new. (It is not complicated, just new).

      If the file is shorter, you can change the offset time to be something closer to the t1 and t2 values.

      The data is your file is fine.

      Brian Savage

      On Jun 9, 2021, at 4:05 PM, George Helffrich (via IRIS) <sac-help-bounce<at>lists.ds.iris.edu> wrote:

      Dear Aubreya -

      What this message means is that the values in the T1 and T2 markers are so big that the coarseness of their 32 bit numerical representation is bigger than the sample rate. Most real numbers can’t be represented exactly digitally by a computer, but only with some imprecision. (The bigger a number is, the less precise it is.) When the imprecision of a SAC time marker (like T1 or T2 in the file header) can’t even pin the time down to within a given sample in the file, you will get this message.

      This message is new to newer versions of SAC, which is why you might not have seen it before.

      Whether this matters to you depends on what T1 and T2 mean. If they are markers for a signal onset, in the trace, that’s probably bad. If they are markers for when an earthquake happened relative to the zero time of the file, that may be OK if all they represent is a time window.

      SAC’s SYNCHRONIZE command can help change file times by moving the file’s zero time so that offsets from it (like T1 and T2) become smaller and can be represented more precisely. See section 4.6 in the SAC book for details about time representation in SAC files.

      On 9 Jun 2021, at 09:51, Aubreya Adams (via IRIS) <sac-help-bounce<at>lists.ds.iris.edu <sac-help-bounce<at>lists.ds.iris.edu>> wrote:

      I’ve just recently downloaded SAC (v102.0) onto a new loaner Mac (OS 10.15.7 Catalina) while my own is getting repairs. I’ve getting an error message like the one below when I read in data:

      SAC> r XO.LT20..HHZ.M__at__2019-03-01T08.59.06.412Z.SAC
      WARNING: minimum precision > sampling rate: t1 = 2392957.750000
      sampling rate (delta): 0.010000
      32-bit minimum precision: 0.250000
      WARNING: minimum precision > sampling rate: t2 = 2392957.750000
      sampling rate (delta): 0.010000
      32-bit minimum precision: 0.250000

      The machine I’m on is 64-bit. And the data file seems fine - I’ve read it on previous versions of sac on both Macs and Linux platforms.

      Any ideas of what is going on or how I might fix this?

      Thanks,
      Aubreya

      ----------------------
      SAC Help
      Topic home: http://ds.iris.edu/message-center/topic/sac-help/ https://urldefense.proofpoint.com/v2/url?u=http-3A__ds.iris.edu_message-2Dcenter_topic_sac-2Dhelp_&d=DwMFaQ&c=dWz0sRZOjEnYSN4E4J0dug&r=xlrnQuY_RWoRIvnCDJ5AfQ&m=k8MQ1ccLIO8eouile3F0b1GlVX9pZ5oNkytwOWjH96k&s=zreKbydXzr0poGeguXqMK666WYVyqA6VRtu5-5ifK3U&e= | Unsubscribe: sac-help-unsubscribe<at>lists.ds.iris.edu <sac-help-unsubscribe<at>lists.ds.iris.edu>

      Sent from the IRIS Message Center (http://ds.iris.edu/message-center/ https://urldefense.proofpoint.com/v2/url?u=http-3A__ds.iris.edu_message-2Dcenter_&d=DwMFaQ&c=dWz0sRZOjEnYSN4E4J0dug&r=xlrnQuY_RWoRIvnCDJ5AfQ&m=k8MQ1ccLIO8eouile3F0b1GlVX9pZ5oNkytwOWjH96k&s=dmgLIdZYfG41jHaB98GtdT4__emEAvdw-yqWm4bKi1w&e=)
      Update subscription preferences at http://ds.iris.edu/account/profile/ https://urldefense.proofpoint.com/v2/url?u=http-3A__ds.iris.edu_account_profile_&d=DwMFaQ&c=dWz0sRZOjEnYSN4E4J0dug&r=xlrnQuY_RWoRIvnCDJ5AfQ&m=k8MQ1ccLIO8eouile3F0b1GlVX9pZ5oNkytwOWjH96k&s=Kj_KK1aHBunvrLzeVN4PqMhv6HPHki-zL2X7LMusX5s&e=



      George Helffrich
      george<at>elsi.jp <george<at>elsi.jp>

      ----------------------
      SAC Help
      Topic home: https://urldefense.proofpoint.com/v2/url?u=http-3A__ds.iris.edu_message-2Dcenter_topic_sac-2Dhelp_&d=DwICAg&c=dWz0sRZOjEnYSN4E4J0dug&r=xlrnQuY_RWoRIvnCDJ5AfQ&m=k8MQ1ccLIO8eouile3F0b1GlVX9pZ5oNkytwOWjH96k&s=zreKbydXzr0poGeguXqMK666WYVyqA6VRtu5-5ifK3U&e= | Unsubscribe: sac-help-unsubscribe<at>lists.ds.iris.edu

      Sent from the IRIS Message Center (https://urldefense.proofpoint.com/v2/url?u=http-3A__ds.iris.edu_message-2Dcenter_&d=DwICAg&c=dWz0sRZOjEnYSN4E4J0dug&r=xlrnQuY_RWoRIvnCDJ5AfQ&m=k8MQ1ccLIO8eouile3F0b1GlVX9pZ5oNkytwOWjH96k&s=dmgLIdZYfG41jHaB98GtdT4__emEAvdw-yqWm4bKi1w&e= )
      Update subscription preferences at https://urldefense.proofpoint.com/v2/url?u=http-3A__ds.iris.edu_account_profile_&d=DwICAg&c=dWz0sRZOjEnYSN4E4J0dug&r=xlrnQuY_RWoRIvnCDJ5AfQ&m=k8MQ1ccLIO8eouile3F0b1GlVX9pZ5oNkytwOWjH96k&s=Kj_KK1aHBunvrLzeVN4PqMhv6HPHki-zL2X7LMusX5s&e=


    • Arthur Snoke
      2021-06-09 18:26:05
      Expanding a little on what George says ...

      The header variables in SAC for reals are 32 bit, and that cannot be changed
      without sacrificing  compatibility with older SAC data files.  In 102.0, we
      introduced some work-around that help researchers deal with larger times, etc.,,
      but header variables like T1 and T2 are still 32 bit.  See the Overview section
      in http://ds.iris.edu/files/sac-manual/manual/intro.html and follow the links to
      see a more complete discussion.

      On 6/9/21 4:05 PM, George Helffrich (via IRIS) wrote:
      Dear Aubreya -

      What this message means is that the values in the T1 and T2 markers are so big
      that the coarseness of their 32 bit numerical representation is bigger than
      the sample rate.  Most real numbers can’t be represented exactly digitally by
      a computer, but only with some imprecision.  (The bigger a number is, the less
      precise it is.)  When the imprecision of a SAC time marker (like T1 or T2 in
      the file header) can’t even pin the time down to within a given sample in the
      file, you will get this message.

      This message is new to newer versions of SAC, which is why you might not have
      seen it before.

      Whether this matters to you depends on what T1 and T2 mean.  If they are
      markers for a signal onset, in the trace, that’s probably bad.  If they are
      markers for when an earthquake happened relative to the zero time of the file,
      that may be OK if all they represent is a time window.

      SAC’s SYNCHRONIZE command can help change file times by moving the file’s zero
      time so that offsets from it (like T1 and T2) become smaller and can be
      represented more precisely.  See section 4.6 in the SAC book for details about
      time representation in SAC files.

      On 9 Jun 2021, at 09:51, Aubreya Adams (via IRIS)
      <sac-help-bounce<at>lists.ds.iris.edu
      <sac-help-bounce<at>lists.ds.iris.edu>> wrote:

      I’ve just recently downloaded SAC (v102.0) onto a new loaner Mac (OS 10.15.7
      Catalina) while my own is getting repairs.  I’ve getting an error message
      like the one below when I read in data:

      SAC> r XO.LT20..HHZ.M__at__2019-03-01T08.59.06.412Z.SAC
      WARNING:  minimum precision > sampling rate: t1 = 2392957.750000
      sampling rate (delta):      0.010000
      32-bit minimum precision:   0.250000
      WARNING:  minimum precision > sampling rate: t2 = 2392957.750000
      sampling rate (delta):      0.010000
      32-bit minimum precision:   0.250000

      The machine I’m on is 64-bit.  And the data file seems fine - I’ve read it on
      previous versions of sac on both Macs and Linux platforms.

      Any ideas of what is going on or how I might fix this?

      Thanks,
      Aubreya

      ----------------------
      SAC Help
      Topic home: http://ds.iris.edu/message-center/topic/sac-help/
      http://ds.iris.edu/message-center/topic/sac-help/ | Unsubscribe:
      sac-help-unsubscribe<at>lists.ds.iris.edu
      <sac-help-unsubscribe<at>lists.ds.iris.edu>

      Sent from the IRIS Message Center (http://ds.iris.edu/message-center/
      http://ds.iris.edu/message-center/)
      Update subscription preferences at http://ds.iris.edu/account/profile/
      http://ds.iris.edu/account/profile/



      George Helffrich
      george<at>elsi.jp <george<at>elsi.jp>


      ----------------------
      SAC Help
      Topic home: http://ds.iris.edu/message-center/topic/sac-help/ | Unsubscribe: sac-help-unsubscribe<at>lists.ds.iris.edu

      Sent from the IRIS Message Center (http://ds.iris.edu/message-center/)
      Update subscription preferences at http://ds.iris.edu/account/profile/


Page built 10:47:37 | v.b'ea7a92