Thread: sac problems with MacOSx 10.7

Started: 2012-01-25 01:01:18
Last activity: 2012-01-25 01:32:11
Topics: SAC Help
jose rial
2012-01-25 01:01:18
Hi;
I'm running SAC on Mac OSX 10.7.2 and thought it installed correctly and
seems to work OK, it crashes a lot. It
crashes sometimes as in the example below after seemingly routine
commands, like read and plot. Sometimes it crashes for
a segmentation fault, without apparent motive, just when plot is invoked.



SAC> lp co .001 n 4 p 2
SAC> p
SAC> xlim 8000 20000
SAC> p
SAC> ls
159.18E 72.82S.txt TALDICE_18O_TALDICE1_8-25ka.txt
HP [Converted].jpg cucu.sac
HP.ai taldice.sac
Stenni et al_Nature Geoscience_2011.pdf untitled [Converted].jpg
TALDICE-d18Orecord_8-25kyr.xls untitled.ai
SAC> r taldice.sac
SAC> p
Assertion failed: (dpy->xcb->pending_requests_tail->next == NULL),
function append_pending_request, file xcb_io.c, line 129.

Other times it crashes due to an apparent segmentation fault.

If sac is launched again it fails right off the bat, so I have to
restart my computer in order for it to work for another, say half hour,
until it crashes again...

Does anyone have similar problems?

Thanks,

JRial

  • Arthur Snoke
    2012-01-25 01:32:11
    Alas ... the developers do not have access to a Mac OS 10.7 computer so
    were not able to test it. We assumed -- perhaps erroneously -- that the
    changes from 10.6 would not affect SAC.

    I am assuming you using the binary. True? If so, could you try building
    from sources and let me know.

    Within a day or so v101.5b will be out, so I suggest you wait -- but
    request the source distribution.

    On Tue, 24 Jan 2012, jose rial wrote:

    Hi;
    I'm running SAC on Mac OSX 10.7.2 and thought it installed correctly and
    seems to work OK, it crashes a lot. It
    crashes sometimes as in the example below after seemingly routine commands,
    like read and plot. Sometimes it crashes for
    a segmentation fault, without apparent motive, just when plot is invoked.



    SAC> lp co .001 n 4 p 2
    SAC> p
    SAC> xlim 8000 20000
    SAC> p
    SAC> ls
    159.18E 72.82S.txt TALDICE_18O_TALDICE1_8-25ka.txt
    HP [Converted].jpg cucu.sac
    HP.ai taldice.sac
    Stenni et al_Nature Geoscience_2011.pdf untitled [Converted].jpg
    TALDICE-d18Orecord_8-25kyr.xls untitled.ai
    SAC> r taldice.sac
    SAC> p
    Assertion failed: (dpy->xcb->pending_requests_tail->next == NULL), function
    append_pending_request, file xcb_io.c, line 129.

    Other times it crashes due to an apparent segmentation fault.

    If sac is launched again it fails right off the bat, so I have to restart my
    computer in order for it to work for another, say half hour, until it crashes
    again...

    Does anyone have similar problems?

    Thanks,

    JRial


Page built 08:07:39 | v.b'ea7a92