Thread: Floating Point Exception

Started: 2012-03-12 20:31:43
Last activity: 2012-03-13 23:21:16
Topics: SAC Help
Schubitzke, Paul W
2012-03-12 20:31:43
Hello List,
We have just attempted to run sac-101.5c-linux_x86_64 on a machine running 64-bit SuSE Linux Enterprise Desktop 10.3, and are immediately greeted with a floating point exception.
A previous 32 bit version of SAC ran ok on this machine.
Any assistance would be greatly appreciated.

# cat /etc/SuSE-release
SUSE Linux Enterprise Desktop 10 (x86_64)
VERSION = 10
PATCHLEVEL = 3

The user's .bashrc contains the following lines:

export SACHOME=/home/USER/SAC
source ${SACHOME}/bin/sacinit.sh

Thanks!
Paul Schubitzke
Systems Administrator - Catapult Technology
Bureau of Reclamation - Geophysics and Seismotectonics
pschubitzke<at>usbr.gov<pschubitzke<at>usbr.gov>
Office: 303.445.3365
Mobile: 303.249.5966


  • Arthur Snoke
    2012-03-13 23:21:16
    I do not work on Linux and we do not have any SuSE machines readily
    accessible, so I can only make suggestions.

    The simplest thing for you would probably be to get the source
    distribution and build it on your system.

    You say you used a previous 32-bit binary on the same machine. There is a
    32-bit binary of SAC v101.5c you might try. (I am not sure how this can
    work with mixing libraries, but I am told that in principle a 32-bit
    binary can run on a 64-bit machine.)

    My impression is that there is enough variation among the different flavors
    of Linux that it is amazing that our pre-built binaries run on as many
    platforms as they do. In the original v101.5 the 64-bit binary did not
    work on older systems because of library issues. Your is the first report
    of a problem with v101.5c. If anyone else has a machine running 64-bit
    SuSE Linux Enterprise Desktop 10.3 and has not had the problem you report,
    it would be useful if they could contact the list.

    On Mon, 12 Mar 2012, Schubitzke, Paul W wrote:

    We have just attempted to run sac-101.5c-linux_x86_64 on a machine
    running 64-bit SuSE Linux Enterprise Desktop 10.3, and are immediately
    greeted with a floating point exception.

    A previous 32 bit version of SAC ran ok on this machine.
    Any assistance would be greatly appreciated.

    # cat /etc/SuSE-release

    SUSE Linux Enterprise Desktop 10 (x86_64)
    VERSION = 10
    PATCHLEVEL = 3

    The user’s .bashrc contains the following lines:

    export SACHOME=/home/USER/SAC
    source ${SACHOME}/bin/sacinit.sh

    Thanks!

    Paul Schubitzke
    Systems Administrator – Catapult Technology
    Bureau of Reclamation – Geophysics and Seismotectonics
    pschubitzke<at>usbr.gov
    Office: 303.445.3365
    Mobile: 303.249.5966
Page built 07:39:20 | v.b'ea7a92