Thread: Compiling SAC on M1 Mac - readline capability

Started: 2022-03-24 09:49:11
Last activity: 2022-03-24 09:49:11
Topics: SAC Help
Sheila Peacock
2022-03-24 09:49:11
Dear all,

we have compiled SAC v. 102 from source on an M1 Mac but found this problem, which we think is to do with a library required by "readline":

When you first run it, you gat a SAC> prompt and you can type a command, cursor back through it, edit it etc

When you press return, the prompt becomes SAC> + the last command you typed and cursor editing no longer works. You can however type in a new command. It doesn't appear to be cumulative, always SAC> + last command typed.

I've tried compiling both with and without readline. I am using 'homebrew' and compilation is using the Apple compiler. I tried installing gcc and using that, but it seemed to make no difference other than making it take twice as long to compile.

No other program that we've installed so far on the M1 shows a problem like this.

Any suggestions would be welcome.

Thanks!

Sheila Peacock,
Blacknest.



Page built 19:37:15 | v.b'59d0d2