Thread: SAC precision problems

Started: 2017-08-28 07:41:10
Last activity: 2017-08-28 22:42:14
Topics: SAC Help
Igor
2017-08-28 07:41:10
Hello,

I am using the ver 101.6a on Linux 64 bit.
While displaying a long time series (4 days, 100 sps file in my case), I
noticed that SAC cannot display the data properly in the second half of the
file. It seems there is not enough precision on the x axis to handle the
time.

How do I correctly display the data? Please see the screenshots attached. I
am comparing the same data obtained from different sources which can be
ignored. Both time series display the same problems.

Thank you,
Igor

  • Arthur Snoke
    2017-08-28 22:31:34
    Igor,

    It is a precision problem within SAC. See the attached PDF file, excerpted from a presentation Brian Savage and I made at an ES SSA meeting a few years ago.

    If you browse the sac-help archives, you will see several exchanges about this problem and possible work-arounds written mostly by Brian, who is on vacation right now. The good news is that the data are not affected, just its presentation and possibly some processing. Ways to deal with it include working with shorter time series (open your file and use cut;r) and decimating the data. This question comes up often enough that I may include an example in docs/examples or in macros/demo showing possible approaches. Please send me a troublesome file (not to the whole list) as I do not have a good time series.

    Arthur
    snoke<at>vt.edu <snoke<at>vt.edu>

    On Aug 28, 2017, at 3:42 AM, Igor <stubailo<at>gmail.com> wrote:

    Hello,

    I am using the ver 101.6a on Linux 64 bit.
    While displaying a long time series (4 days, 100 sps file in my case), I noticed that SAC cannot display the data properly in the second half of the file. It seems there is not enough precision on the x axis to handle the time.

    How do I correctly display the data? Please see the screenshots attached. I am comparing the same data obtained from different sources which can be ignored. Both time series display the same problems.

    Thank you,
    Igor


    <allData4d.png><30sec.png><80000sec.png><170000sec.png><330000sec.png>
    ----------------------
    SAC Help | http://ds.iris.edu/message-center/topic/sac-help/ | Unsubscribe: sac-help-unsubscribe<at>lists.ds.iris.edu

    Sent from the IRIS Message Center (http://ds.iris.edu/message-center/)
    Update subscription preferences at http://ds.iris.edu/account/profile/


  • Arthur Snoke
    2017-08-28 22:42:14
    I apparently forgot to attach the file.


    Attachments
    • Igor
      2017-08-28 20:14:28
      Arthur,

      Got it, thank you.
      So my 4 days at 100 sps totally killed the SAC precision.
      I will keep that in mind, do not go over 1.5 days at 100 Hz or downsample
      the data.
      I am sure as we move forward to 64-bits everywhere and an improved GPS data
      quality, this becomes an issue.

      -Igor

      On Mon, Aug 28, 2017 at 12:42 PM, Arthur Snoke <snoke.ja<at>gmail.com> wrote:

      I apparently forgot to attach the file.



Page built 05:16:30 | v.b'59d0d2