Thread: Problem with transfer function

Started: 2012-12-24 22:31:54
Last activity: 2012-12-25 18:49:55
Topics: SAC Help
Abhash Kumar
2012-12-24 22:31:54
Hi,
I am using transfer function in sac to remove the instrument response.
I have checked my pole-zero file and there is no special character in any
of the line. I also switched the line (either first line or last line) to
specify the value of constant and using 'to none' option as well but the
error persist. I have done it as shown below:

SAC> r 2012.011.18.57.FM09.BHZ
SAC> rmean
SAC> rtr
SAC> taper
SAC> transfer from polezero s FM09_ZVBB.zp to none
ERROR 1:

Next time I used the frequency limit as well to remove the response:

SAC> r 2012.011.18.57.FM09.BHZ
SAC> rmean
SAC> rtr
SAC> taper
SAC> transfer from polezero s FM09_ZVBB.zp to none freq 0.05 0.1 30 50
ERROR 1:

My pole-zero file look like this:

CONSTANT 3.605e+17
ZEROS 2
0.00E+00 0.00E+00
0.00E+00 0.00E+00
POLES 5
-3.701E-02 3.701E-02
-3.701E-02 -3.701E-02
-1.131E+03 0.000E+00
-1.005E+03 0.000E+00
-5.027E+02 0.000E+00

I am using this same process and same format of pole-zero files for other
stations and majority of the stations have no problem but few stations are
behaving in weird manner. Is there any other way to avoid this situation
and get the instrument response removed correctly.

Thanks
Abhash Kumar
University of North Carolina at Chapel Hill

  • George Helffrich
    2012-12-25 16:53:24
    Dear All -

    I suggest that you take a debugging approach to understanding how the problem arises. I see that one of your numbers has a lower case e+NN, whereas the others are upper case. Does this affect the result?

    Replace each line successively from the pole-zero file with 0 0 (or simply delete it, which substitutes the value 0 0). When does the problem go away? That will be the bad line.

    On 24 Dec 2012, at 19:31, Abhash Kumar wrote:

    Hi,
    I am using transfer function in sac to remove the instrument response. I have checked my pole-zero file and there is no special character in any of the line. I also switched the line (either first line or last line) to specify the value of constant and using 'to none' option as well but the error persist. I have done it as shown below:

    SAC> r 2012.011.18.57.FM09.BHZ
    SAC> rmean
    SAC> rtr
    SAC> taper
    SAC> transfer from polezero s FM09_ZVBB.zp to none
    ERROR 1:

    Next time I used the frequency limit as well to remove the response:

    SAC> r 2012.011.18.57.FM09.BHZ
    SAC> rmean
    SAC> rtr
    SAC> taper
    SAC> transfer from polezero s FM09_ZVBB.zp to none freq 0.05 0.1 30 50
    ERROR 1:

    My pole-zero file look like this:

    CONSTANT 3.605e+17
    ZEROS 2
    0.00E+00 0.00E+00
    0.00E+00 0.00E+00
    POLES 5
    -3.701E-02 3.701E-02
    -3.701E-02 -3.701E-02
    -1.131E+03 0.000E+00
    -1.005E+03 0.000E+00
    -5.027E+02 0.000E+00

    I am using this same process and same format of pole-zero files for other stations and majority of the stations have no problem but few stations are behaving in weird manner. Is there any other way to avoid this situation and get the instrument response removed correctly.

    Thanks
    Abhash Kumar
    University of North Carolina at Chapel Hill



    George Helffrich
    george.helffrich<at>bris.ac.uk



    • Pablo.Palacios@bristol.ac.uk
      2012-12-25 18:49:55
      Dear Abhash Kumar

      Only in case, which operative system created your pole-zeros file? Some
      times you can have troubles with the end of the line, because
      linux/unix-like and windows use different format (a hidden special
      character for the end of line). Make a copy of your file and try with some
      "convert new lines" program before use SAC (for instance:
      http://osx.iusethis.com/app/convertnewlines).

      P.

      On Tue, December 25, 2012 8:53 am, George Helffrich wrote:
      Dear All -

      I suggest that you take a debugging approach to understanding how the
      problem arises. I see that one of your numbers has a lower case e+NN,
      whereas the others are upper case. Does this affect the result?

      Replace each line successively from the pole-zero file with 0 0 (or
      simply delete it, which substitutes the value 0 0). When does the
      problem go away? That will be the bad line.

      On 24 Dec 2012, at 19:31, Abhash Kumar wrote:

      Hi,
      I am using transfer function in sac to remove the instrument
      response. I have checked my pole-zero file and there is no special
      character in any of the line. I also switched the line (either
      first line or last line) to specify the value of constant and using
      'to none' option as well but the error persist. I have done it as
      shown below:

      SAC> r 2012.011.18.57.FM09.BHZ
      SAC> rmean
      SAC> rtr
      SAC> taper
      SAC> transfer from polezero s FM09_ZVBB.zp to none
      ERROR 1:

      Next time I used the frequency limit as well to remove the response:

      SAC> r 2012.011.18.57.FM09.BHZ
      SAC> rmean
      SAC> rtr
      SAC> taper
      SAC> transfer from polezero s FM09_ZVBB.zp to none freq 0.05 0.1 30 50
      ERROR 1:

      My pole-zero file look like this:

      CONSTANT 3.605e+17
      ZEROS 2
      0.00E+00 0.00E+00
      0.00E+00 0.00E+00
      POLES 5
      -3.701E-02 3.701E-02
      -3.701E-02 -3.701E-02
      -1.131E+03 0.000E+00
      -1.005E+03 0.000E+00
      -5.027E+02 0.000E+00

      I am using this same process and same format of pole-zero files for
      other stations and majority of the stations have no problem but few
      stations are behaving in weird manner. Is there any other way to avoid
      this situation and get the instrument response removed correctly.

      Thanks
      Abhash Kumar
      University of North Carolina at Chapel Hill



      George Helffrich
      george.helffrich<at>bris.ac.uk


      _______________________________________________
      sac-help mailing list
      sac-help<at>iris.washington.edu
      http://www.iris.washington.edu/mailman/listinfo/sac-help



      --


Page built 05:33:33 | v.b'59d0d2